References
Abadi, Daniel J. 2012. “Consistency Tradeoffs in Modern
Distributed Database System Design: CAP Is Only Part of the
Story.” Computer 45 (2): 37–42. https://doi.org/10.1109/MC.2012.33.
Accenture. 2022. ASX CHESS Replacement
Application Delivery Review. Accenture, published by the Australian
Securities; Investments Commission (Report 23-035). https://download.asic.gov.au/media/ku2aa1kz/23-035-asx-chess-replacement-application-delivery-review-2022.pdf.
Androulaki, Elli, Artem Barger, Vita Bortnikov, et al. 2018.
“Hyperledger Fabric: A Distributed Operating System for
Permissioned Blockchains.” Proceedings of the Thirteenth
EuroSys Conference (EuroSys ’18). https://doi.org/10.1145/3190508.3190538.
A.P. Moller - Maersk. 2022. A.p. Moller - Maersk and
IBM to Discontinue TradeLens, a
Blockchain-Enabled Global Trade Platform. https://www.maersk.com/news/articles/2022/11/29/maersk-and-ibm-to-discontinue-tradelens.
ascribe team. n.d. Ascribe Is No Longer
Active. Accessed October 12, 2026. https://www.ascribe.io/.
ASX Limited. 2022. CHESS Replacement: ASX
Reassessing Solution Design and Financial Derecognition. Market
release, reproduced by Mondo Visione. https://mondovisione.com/media-and-resources/news/chess-replacement-asx-reassessing-financial-derecognition-20221117/.
Birkholz, Henk, Antoine Delignat-Lavaud, Cédric Fournet, Yogesh
Deshpande, and Steve Lasker. 2026. An Architecture for Trustworthy
and Transparent Digital Supply Chains. RFC 9943. https://doi.org/10.17487/RFC9943.
Cisco. 2024. More Than 1 in 4 Organizations Banned Use of
GenAI over Privacy and Data Security Risks. https://newsroom.cisco.com/c/r/newsroom/en/us/a/y2024/m01/organizations-ban-use-of-generative-ai-over-data-privacy-security-cisco-study.html.
CNN. 2024. British Engineering Giant Arup Revealed as
$25 Million Deepfake Scam Victim. https://edition.cnn.com/2024/05/16/tech/arup-deepfake-scam-loss-hong-kong-intl-hnk.
Coalition Against Insurance Fraud. 2022. The Impact of Insurance
Fraud on the U.S. Economy. https://insurancefraud.org/wp-content/uploads/The-Impact-of-Insurance-Fraud-on-the-U.S.-Economy-Report-2022-8.26.2022.pdf.
Cooper, Brian F., Raghu Ramakrishnan, Utkarsh Srivastava, et al. 2008.
“PNUTS: Yahoo!’s Hosted Data Serving
Platform.” Proceedings of the VLDB Endowment 1 (2):
1277–88. https://doi.org/10.14778/1454159.1454167.
Dubai Land Department. 2025. Dubai Land Department Launches Pilot
Phase of the Real Estate Tokenisation Project. https://dubailand.gov.ae/en/news-media/dubai-land-department-launches-pilot-phase-of-the-real-estate-tokenisation-project.
Energinet. 2023. Project Origin: Connecting the Dots from Energy
Production to Consumption. LF Energy Summit presentation. https://static.sched.com/hosted_files/lfenergysummit2023/e0/Project%20Origin%20pitch_deck_Polygraphic_Ver3_Paris_Nicolas_Bernhardi_Energinet.pdf.
Etherscan. 2026. Ethereum Daily Transactions Chart. https://etherscan.io/chart/tx.
European Parliament and Council. 2024. Regulation (EU)
2024/1781 of 13 June 2024 Establishing a Framework for the Setting of
Ecodesign Requirements for Sustainable Products, Amending Directive
(EU) 2020/1828 and Regulation (EU) 2023/1542
and Repealing Directive 2009/125/EC. Official Journal
of the European Union, L, 28.6.2024. https://eur-lex.europa.eu/eli/reg/2024/1781/oj.
EventChain. 2026a. EventChain: Open Haskell
Implementation. Https://github.com/eventchain-protocol/eventchain.
EventChain. 2026b. Hub Append Rate: What Checking Each Line Before
Appending It Costs. Reproducible reference-implementation
benchmark.
EventChain. 2026c. Minimal Actual-File Verifier Evidence.
Reproducible reference-implementation benchmark.
EventChain. 2026d. Producer Batching: What Signing Events in Batches
Buys Under Contention. Reproducible reference-implementation
benchmark.
EventChain Protocol. 2026. EventChain Hub Reference
Implementation. GitHub repository. https://github.com/eventchain-protocol/hub.
FIDO Alliance. 2026. FIDO Alliance Reports Accelerating
Global Passkey Adoption on World Passkey Day 2026. https://fidoalliance.org/fido-alliance-reports-accelerating-global-passkey-adoption-on-world-passkey-day-2026/.
Google. 2026. Trillian: General Transparency.
GitHub repository. https://github.com/google/trillian.
Gottlieb, Glenn. 2026. The Quiet Winners: Enterprise Blockchain
Applications That Deliver Durable Value. Ecosystem Insights.
Architect Partners. https://architectpartners.com/wp-content/uploads/2026/02/The-Quiet-Winners_Enterprise-Blockchain-Application-That-Deliver-Durable-Value.pdf.
Haber, Stuart, and W. Scott Stornetta. 1991. “How to Time-Stamp a
Digital Document.” Journal of Cryptology 3 (2): 99–111.
https://doi.org/10.1007/BF00196791.
Hill, Rebecca. 2018. IBM Struggles to Sign up Shipping
Carriers to Blockchain Supply Chain Platform. The Register. https://www.theregister.com/2018/10/30/ibm_struggles_to_sign_up_shipping_carriers_to_blockchain_supply_chain_platform_reports/.
HM Land Registry. 2026. Practice Guide 67: Evidence of
Identity. https://www.gov.uk/government/publications/evidence-of-identity-conveyancers/practice-guide-67-evidence-of-identity-conveyancers.
Hodges, Jeff, J. C. Jones, Michael B. Jones, Akshay Kumar, and Emil
Lundberg. 2021. Web Authentication: An API for
Accessing Public Key Credentials, Level 2. W3C Recommendation. https://www.w3.org/TR/webauthn-2/.
Hong Kong Free Press. 2024. Multinational Loses HK$200
Million to Deepfake Video Conference Scam, Hong Kong Police
Say. https://hongkongfp.com/2024/02/05/multinational-loses-hk200-million-to-deepfake-video-conference-scam-hong-kong-police-say/.
Howard, L. S. 2022. Industry’s Blockchain Project, B3i,
Ceases to Trade After Filing for Insolvency. Carrier Management. https://www.carriermanagement.com/news/2022/08/01/238818.htm.
IBM. 2021. Hapag-Lloyd and Ocean Network Express Complete
TradeLens Integration. IBM Newsroom. https://newsroom.ibm.com/2021-06-24-Hapag-Lloyd-and-Ocean-Network-Express-Complete-TradeLens-Integration,-Join-Rapidly-Expanding-Shipping-Ecosystem-to-Further-Enhance-Trade-Digitization.
Josefsson, Simon. 2006. The Base16, Base32, and Base64 Data
Encodings. RFC 4648. https://doi.org/10.17487/RFC4648.
JSON Lines. 2023. JSON Lines. Https://jsonlines.org/.
Laurie, Ben, Adam Langley, and Emilia Kasper. 2013. Certificate
Transparency. RFC 6962. https://doi.org/10.17487/RFC6962.
Li, Jinyuan, Maxwell Krohn, David Mazières, and Dennis Shasha. 2004.
“Secure Untrusted Data Repository (SUNDR).”
6th Symposium on Operating Systems Design and Implementation
(OSDI), 121–36. https://www.usenix.org/legacy/event/osdi04/tech/full_papers/li_j/li_j.pdf.
Malik, Sidra, Volkan Dedeoglu, Salil S. Kanhere, and Raja Jurdak. 2019.
“TrustChain: Trust Management in Blockchain and
IoT Supported Supply Chains.” IEEE International
Conference on Blockchain. https://doi.org/10.1109/Blockchain.2019.00032.
Malvai, Harjasleen, Lefteris Kokoris-Kogias, Alberto Sonnino, et al.
2023. “Parakeet: Practical Key Transparency for
End-to-End Encrypted Messaging.” Network and Distributed
System Security Symposium (NDSS). https://www.ndss-symposium.org/ndss-paper/parakeet-practical-key-transparency-for-end-to-end-encrypted-messaging/.
McGee, Scott. 2022. B3i Enters Insolvency After Failing
to Raise Funding. Insurance Post. https://postonline.co.uk/technology/7950336/b3i-enters-insolvency-after-failing-to-raise-funding.
Microsoft. 2026. Windows 11 Requirements. https://learn.microsoft.com/en-us/windows/whats-new/windows-11-requirements.
Najati, Issam. 2025. “Exploring the Failure Factors of Blockchain
Adopting Projects: A Case Study of TradeLens Through the
Lens of Commons Theory.” Frontiers in Blockchain 8. https://doi.org/10.3389/fbloc.2025.1503595.
Nasr, Milad, Nicholas Carlini, Jonathan Hayase, et al. 2023.
Scalable Extraction of Training Data from (Production) Language
Models. arXiv:2311.17035. https://arxiv.org/abs/2311.17035.
National Institute of Standards and Technology. 2015. Secure Hash
Standard (SHS). FIPS Nos. 180-4. NIST. https://doi.org/10.6028/NIST.FIPS.180-4.
National Institute of Standards and Technology. 2023. Digital
Signature Standard (DSS). FIPS Nos. 186-5. NIST. https://doi.org/10.6028/NIST.FIPS.186-5.
OpenTimestamps. 2026. OpenTimestamps: A Timestamping
Proof Standard. https://opentimestamps.org/.
PierNext. 2023. The Closure of TradeLens: When
Technology Is Not Enough. Port de Barcelona. https://piernext.portdebarcelona.cat/en/technology/the-closure-of-tradelens/.
Reddy, Raksha, and Carl Wallace. 2010. Trust Anchor Management
Requirements. RFC 6024. https://doi.org/10.17487/RFC6024.
Rundgren, Anders, Bret Jordan, and Samuel Erdtman. 2020.
JSON Canonicalization Scheme (JCS).
RFC 8785. https://doi.org/10.17487/RFC8785.
Serious Fraud Office. 2026. SFO Secures 4-Year Prison
Sentence for Aircraft Parts Fraud. https://www.gov.uk/government/news/sfo-secures-4-year-prison-sentence-for-aircraft-parts-fraud.
Smith, Samuel M. 2019. Key Event Receipt Infrastructure
(KERI). https://arxiv.org/abs/1907.02143.
Standards for Efficient Cryptography Group. 2009. SEC
1: Elliptic Curve Cryptography, Version 2.0. Certicom Research. https://www.secg.org/sec1-v2.pdf.
Tabak, Nate. 2020. How Walmart Solved Carrier Payment
Woes in Canada with Blockchain. FreightWaves. https://www.freightwaves.com/news/how-walmart-solved-carrier-payment-woes-in-canada-with-blockchain.
Todd, Peter. 2016. OpenTimestamps: Scalable,
Trust-Minimized, Distributed Timestamping with Bitcoin. https://petertodd.org/2016/opentimestamps-announcement.
TradeLens. 2021. Pricing. https://www.tradelens.com/pricing.
UK Parliament. 2023. Electronic Trade Documents Act 2023. https://www.legislation.gov.uk/ukpga/2023/38/enacted.
United Nations Commission on International Trade Law. 2025.
UNCITRAL Model Law on Electronic Transferable Records
(2017): Status. https://uncitral.un.org/en/texts/ecommerce/modellaw/electronic_transferable_records/status.
United Nations ESCAP. 2025. TradeLens.
Cross-Border Paperless Trade Database (Digitalize Trade). https://www.digitalizetrade.org/projects/tradelens.
U.S. Customs and Border Protection. 2026. Uyghur Forced Labor
Prevention Act. https://www.cbp.gov/trade/forced-labor/UFLPA.
U.S. Food and Drug Administration. 2018. Data Integrity and
Compliance with Drug CGMP: Questions and Answers, Guidance
for Industry. U.S. Food; Drug Administration. https://www.fda.gov/media/119267/download.
Wragg, Eleanor. 2022a. Trade’s Blockchain Proponents Face Reality
Check as Hype Fades. Global Trade Review. https://www.gtreview.com/magazine/the-fintech-issue-2022/trades-blockchain-proponents-face-reality-check-as-hype-fades.
Wragg, Eleanor. 2022b. We.trade Calls It Quits After Running Out of
Cash. Global Trade Review. https://www.gtreview.com/news/top-stories/we-trade-calls-it-quits-after-running-out-of-cash/.
Wragg, Eleanor. 2023a. Marco Polo Brings in Liquidators as Funds Run
Dry. Global Trade Review. https://www.gtreview.com/news/fintech/marco-polo-brings-in-liquidators-as-funds-run-dry/.
Wragg, Eleanor. 2023b. Shipping Industry Sets Course for Fully
Paperless Trade. Global Trade Review. https://www.gtreview.com/news/fintech/shipping-industry-sets-course-for-fully-paperless-trade/.